Unable to find valid certification path to requested target

I have API which uses self-signed certificate. I have .pem file and it seems to work in Postman, but I cannot get it to work in Appsmith datasource. Use self-signed certificate is set to yes and I have uploaded the .pem file. When I try to connect to the api, I get unable to find valid certification path to requested target error.

I’m running Appsmith on docker and started it with docker-compose.

@jadev Is this a private or custom SSL certificate?

I guess private self-signed for development purposes. Not sure what is the difference of custom and private… developer just created it.

Got it. If you have that custom CA’s root certificate, follow the docs at https://docs.appsmith.com/setup/instance-configuration/custom-ca-root-certificate to install it into Appsmith and then Appsmith should be able to verify HTTPS connections that use certs that were signed by this CA.

  1. I created ca-certs to stacks folder and copied our root crt there.
  2. Then I restarted appsmith
  3. Added new datasource and then I selected self-signed certificate and uploaded the private crt file

After this, I still get the same error. What I’m missing…?