Trouble with DragNode Fusion Chart on Deploy

Attempting to implement a dragnode chart with a SQL Server data source. When I am in development view, the chart renders; but when I deploy, I only get a blank widget as if there is no data. I have confirmed with a text box that the data source queries are running and are returning data in the correct format.

Has anyone come across something like this?

@amitjag Have you checked whether the query that is bound to the chart widget is set to run on page load? You’ll find this under the Settings tab for that query.

Hi @dancia, yes it indeed is. I tried that, also set up a button to reset the widget in case it is getting into some bad state, and tried another button to refresh the queries even after page load. None of those work. Is there some level of licensing needed for this to work? Running community edition on prem, so I would not put it past me just not knowing something basic that needs to be in place first.

@amitjag I don’t think you require any licensing for it to work. If it is working fine in edit mode, it should show in deployed mode as well. Would it possible for you to share the exported json of this app so that we can debug the issue? If yes, you can email it to me at

Can do! Just shot it over.

Closing the loop here. I ran a sudo apt-get update and sudo apt-get upgrade on the server and the issue was then resolved. Either this solved a dependency or the tried and true “did you try turning it off and on again” technique came through again.