Passing only numbers into a string field actually sends a number to the api instead of a "number" string


Using v1.7.10. After looking at this thread Passing strings containing just numbers in a mustache expression, alway casts back to some number type, even disabling both options:

The value is still sent as a number instead of a string to the api.

How to fix this?

Thank You

Hi! Do you get an error message? Can you share a screenshot of the API and error? A screen recording might also help us debug this.

Here is a screenshot:

The amazon_id error is returned by my api. I verified on my api that appsmith sends a number instead of a string.

Hi @ddorian43
We are wondering why this isn’t working in your case. In practice, having smart substitution turned off and enclosing the value with double quotes should work. Here’s a demonstration with one postman-echo API. Can you please check the video and verify if you are doing the same?

Yes, I was doing the same.
I even tried it with like you did in the video.
I actually discarded the changes and made the change again and this time it worked.

Thank you

1 Like