Move Docker container to New Host


Looking for some assistance here, I am trying to take a Appsmith instance running on “Machine A” and move it over to “Machine B” while retaining the data?

I have tried, docker exporting toe volume, creating images, committing the container, but I have had no success.

The reason I need to move the container is because the current machines hardware is dated and will not allow me to update the mongodb to version 5 which is preventing me to update to appsmith past 1.8.15.

Machine A - Ubuntu Server running Docker
Machine B - Windows 10 running Docker

Any assistance would be greatly appreciated.


Hello there!
Let me reach out to one of our engineers regarding this and give you a response as soon as I have any helpful information to share

Hello! Please follow the steps from our documentation on backup and restore and let us know if you face any issues.

@Amelia I have followed the instructions listed in the documentation, the instructions do not work or should I say they work partially but not completely.

I end up having to copy several of the keys over from the docker.env file and was able to login but was unable to edit the application would end up getting a 503 error

The tags/fields I had to copy into the docker.env from the docker.env.appsmith-backup-xxxx



So any assistance would be appreciated.

Hi there!

After successfully restoring the backup using the appsmithctl restore command, you will only need to change the APPSMITH_ENCRYPTION_PASSWORD=
APPSMITH_ENCRYPTION_SALT= saved from the old instance. And update APPSMITH_MONGODB_URI to the default Mongo URI of the new instance before running the restore command.

If you have already restored the data on the new instance, you have to copy the MONGO env variables from /stacks/configuration/docker.env.appsmith-backup-timestamp to /stacks/configuration/docker.env on the new instance.

Machine 1: Ubuntu
Machine 2: Windows

My process
Machine 1: execute command “docker-compose exec appsmith appsmithctl backup”
Machine 2: setup new instance of appsmith

Machine 1: copy backup file to machine 2 /stacks/data/backup
machine 2: execute command “docker-composer exec appsmith appsmithctl restore”

machine 2: open docker.env and dcoker.env.timestamp…
machine 2: copy over APPSMITH_ENCRYPTION_PASSWORD & APPSMITH_ENCRYPTION_SALT & APPSMITH_MONGODB_URI from the docker.env.timestamped. to docker.env
machine 2: execute command docker-composer restart

Login to the Appsmith system using my credentials, I see that apps but when I click edit button on of of the apps I still get a 503 error!

Still at a lose for where I am going wrong with the backup and restore.

Please send us the server logs to help us investigate the issue. You can grab the logs by running docker logs -f appsmith.
Or you could follow the steps from this guide on how to get the logs

Please see the following link to my Logs file shared via onedrive - windows docker

I have also tried to spin up a new Linux VM (Local) and deploy the appsmith and restore the backup and still receiving the 503 errors when editing

Hey! Thanks for the logs. We’ll have a look and get back to you.

Thank you, Any Updates on what is causing the issues?

Hello Brent! Sorry for the delays. Our team still needs some time to investigate this.

Could you please get on a call with us to debug this issue? Please schedule it using this link - Calendly - Goutham Pratapa

The issue got fixed on the call. appsmithctl restore /backup didn’t work. Our DevOps team is looking into it.
For the time being, it works when taking mongodump and then using appsmithctl import_db.