Invitation email not sended


Docker install:
Admin email setup is sending test email.

Invitation email is not coming/going.

What could be reason?
Where i see log about that?


Hey @seamus3033, welcome to the Appsmith community. Sorry you are facing trouble here. Can you share the logs from stacks/logs/backend/backend.log file from your self-hosted installation, when you see this error please?


Hey @sharat87

I am facing same issue, I checked the logs and found out exception is raised while sending emails via Amazon SES. Test email worked fine, I did follow setup guide on available on Amazon SES - Appsmith


 - Unable to send email. Cause:
org.springframework.mail.MailSendException: Failed messages: com.sun.mail.smtp.SMTPSendFailedException: 554 Transaction failed: Empty address

	at org.springframework.mail.javamail.JavaMailSenderImpl.doSend(
	at org.springframework.mail.javamail.JavaMailSenderImpl.send(
	at org.springframework.mail.javamail.JavaMailSenderImpl.send(
	at com.appsmith.server.notifications.EmailSender.sendMailSync(
	at com.appsmith.server.notifications.EmailSender.lambda$sendMail$1(
	at reactor.core.publisher.FluxPeekFuseable$PeekFuseableSubscriber.onNext(
	at reactor.core.publisher.Operators$MonoSubscriber.complete(
	at reactor.core.publisher.MonoCallable.subscribe(
	at reactor.core.publisher.Mono.subscribe(
	at reactor.core.publisher.MonoSubscribeOn$
	at java.base/
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/


Please let me know how can I fix this?


Hey Team, I am still not able to figure this out. Can you please help me?

cc: @Nikhil


Hey, sorry this got missed. Can you share the value of APPSMITH_MAIL_FROM in your docker.env file? If its not present, or is empty, can you set it to something like, and restart and see it this helps please?

@monarch0111 is this working now?

Thanks @sharat87 for the reply.

I checked in docker.env, it’s set to We have verified that it works well with other application using same credentials. Please find attached screenshot for details.

I believe it’s a bug in the application layer. I was able to send a test mail while setting up SES Email on Appsmith.

Hey @Nikhil , no it’s not working yet. How can I share version details of appsmith or log trace?

Hey @monarch0111 ,
Could you check the value for APPSMITH_REPLY_TO in your docker.env? If it’s empty, could you set it to the same email address that you are using for APPSMITH_MAIL_FROM and restart?
Let us know if that helps or if you still face any issues.

1 Like

Hello @ankitakinger

Thanks for your reply. Yes, setting APPSMITH_MAIL_FROM helped me solve the issue.

Thanks a lot.

1 Like