Intercom problem? - Cannot have more than 120 active event names (422 error code)

errors: [{code: “422”, message: “Cannot have more than 120 active event names”}]

My app is working and showing all the API data that I retrieve, but I am getting an error associated with all of the APIs I call to populate my app.

When I do an inspect and look at the network info I am seeing “events” get a 422 in many instances. The 422 error seems to be associated with calls to intercom. I did a google search on “Cannot have more than 120 active event names” and it shows that as an intercom error.

I don’t receive the errors when I am in Edit mode, just when I launch the live app.

Can you help me understand what I have done or need to undo? This started happening in the last week or two?


@sstava Sorry about the issue you are facing. Are you on Appsmith Cloud or self-hosted? Also just confirming that you see the error message when deploying the app but not thereafter? I’ll loop in someone from engineering to investigate and help debug.

@sstava it would help if you could share a screenshot of where you are seeing the error

I am using Appsmith Cloud

@sstava your API failures are unrelated to this. The network call for your APIs is called execute. Events is a separate problem we have with intercom that should not affect your experience.

Good to know. Thank you! I am still getting the API error messages that I show in my screenshot with the multiple black boxes of errors. Even though I receive those error messages on my screen all of my data comes back for all of my API‘s. Also, I don’t see those errors when I run it in edit mode. When I run each API manually in Appsmith everything works fine and I get data back as well.

Any thoughts on why I am getting those black boxes with the API call error messages?

@sstava that is odd. In the console, can you search for execute and see what is the response of the failed execute network calls?

Each of the “execute” items returns a 200 status as shown in the attached screenshot :slight_smile:

1 Like

@sstava Sorry you are facing this issue. We have created an issue on Github and can be tracked here.-[Bug]: Apps show error - `The action ... has failed` on page load · Issue #14141 · appsmithorg/appsmith · GitHub

@sstava I also got a error like this. You can check this link Error while deploying the Application - #10 by lavanya1
I think there is a difficulty in displaying the data. After changing the column type in table columns i got this error. In my case while displaying the data in table I got this error. so i thought it is because of change in column type.I tried with new table widget without changing the column type it worked.(by deleting old table in my case)

1 Like

omg, I thought it was only me… I get these errors on Cloud and self-hosted versions

1 Like

Our fix for this issue is nearly ready and will go live very soon: fix: reduced the call for fetchPublishedPage action to single by AmanAgarwal041 · Pull Request #14210 · appsmithorg/appsmith · GitHub