How can I reclaim access to self-hosted applications associated with an account I can't access?

Good day! I’ve lost access to the Appsmith applications I was developing locally. The supporting files/data exist (all the Docker containers are running), but I cannot reconnect to the Appsmith account under which I developed them.

Context: I’m working with a self-hosted instance of Appsmith using Docker. I have multiple running networked containers (for a database and other services), most with associated volumes, so that I can persist essential data to Windows locally (e.g., Appsmith’s “stacks”). I have enabled the watchtower service, which notified me today of an update to the Appsmith codebase. Clicking on the “REFRESH” link in the alert dialog took me to an Appsmith login page. I couldn’t remember my password, so I attempted to reset it, but a reset link was never forthcoming (even after configuring SMTP properly in the docker.env file). Subsequently, I created a new user account, but the applications I hoped to see didn’t materialize as selections.

I haven’t tried export_db/import_db yet ( Instead, I was hoping someone reading might know of a configuration tweak (inside or outside a Docker container) that could resolve the account disconnect. :wink: Thank you for your kind attention.

BTW, Appsmith is fantastic! Kudos to those who’ve found a way to bring database application development to the masses. :slight_smile:

To clarify the preceding post (by putting a face on the problem), I can log in to with my email address and password (not via a Google or GitHub account) via the following interface:

However, I can not use that same account to log in to my self-hosted (“on prem”) instance, although I could before I attempted to update appsmith via watchtower:

If I have misunderstood how things are supposed to work, I’m happy to be corrected.

@bfegley Apologies for the issues you are facing with your self-hosted instance. @sharat87 could you help troubleshoot this, please? Thanks

Hey @bfegley, I’m assuming your deployment is based on a docker-compose.yml file, right? If yes, this is what you can do to restore access to your account. Note that this is undocumented, but should work well with today’s version of Appsmith.

SSH into your server and change to the directory containing the docker-compose.yml file. Here, run the following command, replacing USER_EMAIL with the email of the account your want to restore:

docker-compose exec appsmith mongo "$(awk -F= '$1 == "APPSMITH_MONGODB_URI" {print $2}' stacks/configuration/docker.env | cut -d '?' -f1)" --eval "db.user.updateOne({email: 'USER_EMAIL'}, {\$set: {source: 'FORM', isEnabled: false}})"

Now, once this is done, go back to your Appsmith Login UI, and now SIGNUP with this email address, and the password that you want to reset to. From here on, you may use this password to access this account.

@sharat87, you’re my new hero; your suggestion worked perfectly! Thank you so much! :hugs: :confetti_ball: