Error importing app from json file generated by appsmith


I’m trying to move an Appsmith app from one server (it was hosted in Google cloud) to a new server (in AWS). I first exported the app from the old instance, which generated a json file. Then, on the new Appsmith instance, I clicked on the ‘import from file’ option and selected the json file generated previously. But Appsmith shows an error saying ‘Internal server error while processing request’. When I refresh the website, it shows the imported app icon, but when I try to open it, it shows again another error saying that it didn’t find the page.

Both instances (old and new) were the same version. I even tried importing the json file from the same instance where I generated the json file, but didn’t work.

I also tried updating the new Appsmith instance to the newest version (1.7.5) but it keeps showing the ‘Internal server error while processing request’ when trying to import the app.

Hope you can have any idea or clue on why this might be happening. Thanks!

I noticed that after deleting a hidden page from the app, I was able to successfully export the app to the new server. But I don’t think this is expected behavior.

@isaacrodgzb Thanks for flagging this. Will share this with the team for investigation and come back with an update as soon as possible

Hi @isaacrodgzb Thanks for sharing this. Would you mind sharing the exported app via DM, if it does not have any sensitive data so that we can investigate this further?