Disable new line with <span> in Text widget

Appsmith version 1.8.13

The text widget inserts an unwanted new line when I use a <span> tag.

this is a <span style=color:#ff0000 ; > span </span> thing
results in:

This is a

I want everything on one line like this (with ‘span’ in red which I can not show here)

This is a span thing

but I can’t do it. This used to work before the (or my) update te version 1.8.13 last week. The span tag is an inline element and should not intoduce a new line like block elements do. I tried to use ‘white-space: nowrap’ and ‘nobr’ to force-disable the new line but that does not work.

How do I disable the new line with the span tag in the text widget?

Hello Tom! Thank you for reporting this issue. We have filed a bug here: [Bug]: Text Widget Inserts New Line When Using <span> Tag · Issue #19442 · appsmithorg/appsmith · GitHub
The team already implemented a fix for it, and it will be available very soon.

Thanks for filing the bug report and to the team for the quick fix! :+1:

v 1.9.2 still does the same thing… :slightly_frowning_face:

Version 1.9.2 included some other important fixes. This one is not out yet, but it will be released soon too.

1 Like

v displays the correct layout without the new lines at each tag