Collaboration problem

Me and 4 other team members are trying to collaborate in the cloud version of AppSmith.

  1. One team member has shared it’s app with the share function and entered the email adresses of the team members.
    They have received an email and made an account through that link. The app that i shared with them has not showed up on their dashboard.

  2. So we decided to try the github tool inside AppSmith, hereby we have made a repo and made branches. On each branch we have implemented a few widgets.
    After that we tried to commit those, which seemed to work fine.

When we try to merge the work to the main branch we get merge conflicts even though we work on different pages and when we have solved the merge conflicts we see the pages on github but not on the cloud interface of AppSmith.

Any help would be much appreciated!

Hello Niels! Welcome to our community!
Please share the following information to help us investigate these issues:

  1. Are the users able to access the app in their URL if you send them the link to it? Could you please share this app with us? Invite as Developer and send us the link to the app so we can check.
  2. For the GitHub merge problem, could you please share a screen recording with the steps you have taken and the issue you get? Please also open the browser’s console so we can see if you get any errors there while executing the steps.
  1. I have invited you. The users are not able to access to the app in through their URL.

  2. The problem with github is that our github repository says that there is a ‘page 2’ in the pages folder but it is not being pulled on the appsmith webapp, when selecting the right branche. It says “No commits to pull”.
    Loom | Free Screen & Video Recording Software | Loom

  1. Could you please confirm if the users signed up with the same email address that you invited when sharing the app? Click the Share button in your app and double-check if the email that appears there is the same one the user uses to access the app. If that’s the case, please try to remove the user, then invite again to check if it still doesn’t work.

  2. Please try to first sync the branches before clicking the pull button:

    After you click the Sync button, you can click the pull button:

  1. It worked. I think we did something wrong at first :smile:

  2. Alright thank you, i think we forgot to sync the branches at first.

Thanks for your quick responses and help