Appsmith v1.7.13 - Cannot connect MySQL datasource, refuses to connect with password

I’m testing out Appsmith, self hosted at the moment in a Docker. Running version 1.7.13.

When I try to connect a MySQL database (V5.7 - not running in a docker) for testing, it will not use the password I entered. I enter it and when I go to test it, it comes back saying ‘using password: NO’ and, well, fails. If I save the datasource entry, then go back in to edit and click to test. Same issue.

I have had a google and found Datasource Errors - Appsmith which says there should be an error stating “Missing password for authentication” if there is no password entered on a datasource when it expects there to be one so I don’t think the password isn’t being saved, but it certainly is not using it to connect.

I’ve tried re-installing Appsmith. I’ve tried connecting to several other MySQL instances, all of which do allow access via other means from the same host I’m running the Docker on so I’m sure its not an issue on the MySQL side.

On the log as far as I can tell it just logs the same message it shows me in the Appsmith interface which is:
‘Error when testing MySQL datasource. io.r2dbc.spi.R2dbcPermissionDeniedException: [1045] [28000] Access denied for user ‘root’@‘’ (using password: NO)’

Any assistance/ideas would be greatly appreciated.

@Teleos Sorry about the issue you are facing. Could you try setting a new password for the user and and see if that resolves the issue? Also what version of MySQL are you using? Appsmith supports MySQL versions 5.5, 5.6, 5.7, and 8.0