Appsmith local setup: Mounts denied

I am using macOS Monterey Version 12.5, Chip Apple M1 Pro

  • Following these steps → 2nd command → docker-compose up -d

I want help with the following two:

  1. My docker desktop is showing black screen after running this command and not working anymore
  2. Also, getting the following error:
ERROR: for appsmith Cannot start service appsmith: Mounts denied:

The path /Users/meetjoshi/Desktop/meetj/appsmith/stacks is not shared from the host and is not known to Docker.

You can configure shared paths from Docker -> Preferences... -> Resources -> File Sharing.

See for more info.


  • Last time I ran this command, same issue occurred with Docker desktop (black screen), and some other error. But, when I visited localhost, appsmith local was working.

  • After that, I followed these steps

  • Still my docker desktop didn’t work

  • It again worked after restarting the computer, but there were no containers and images

  • Also, I wasn’t able to access appsmith local anymore

  • Hence, I repeated the steps as above, and now getting a different error

Hi there!
I think this might be an issue with Docker and not Appsmith.
When I was using macOS Monterey, I also encountered a couple of issues with Docker while using appsmith with other NodeJS and Go projects (not even Appsmith). However, when I upgraded to the latest Ventura Version, Docker became more compatible and gave me fewer issues.

Can you consider upgrading your OS to Ventura 13.1

1 Like