API execution error

Hi there,
I try to make a POST request but have an error:

[PE-RST-5000] Your API failed to execute
[DownstreamError] org.springframework.http.InvalidMediaTypeException: Invalid mime type “json”: does not contain ‘/’

I can successfully run the same request from my local insomnia or postman. I tried to add “accept”: “application/json” to the header but nothing changed.
Made the same request from Xano (no code app) and it was successful.

I’m a newbie so please let me know if I should add some additional info.
Appreciate any help with it!

Hello @Human!

I’m Jimmy with Appsmith support. :wave:

Let’s resolve this issue by first confirming the syntax correctness for the Query and JS elements that you are using. Also, let’s check if it’s not just a timeout issue, which you can resolve by increasing the timeout from the settings tab. To further debug the issue, I need some information to understand the problem:

  1. What is the query/API for?
  2. Please share a Loom video (screen recording) demonstrating the steps leading up to the error and showing the actual error from the debug (error) panel.

Hi @Laguna,

I increased the timeout, but this doesn’t help.

  1. To fetch call recordings from VoIP service.
  2. Sorry, I can’t share the screen recording because this is not a public endpoint and Loop can’t properly blur what I need to hide.
    But I will share screenshots, hope this will help.

Problem with mime type so I tried to add “Accept: application/json” to the headers but it doesn’t help. Tried to add to the header “Content-Type: application/json” but this also doesn’t help.

As I told I was able successfully run the same request in Xano, here is the screenshot from it:

@Human Can you please provide screenshots of your configuration in Insomnia and Postman?

The only required parameter is api_key